Archive

Archive for April, 2009

Quakelive on Linux

April 8, 2009 Leave a comment

Its just not understandable when you see Quakelive for Windows but nothing like a native Linux installation. It simply sucks for me as I dont have a dual boot with the crappy old Windows on it.

I just tried installing Quakelive on Linux and it went sweeet, so wanted to share if it could help someone.

I have Ubuntu 8.1 with Wine 1.0.1, the process is something like this:

–> Install Firefox for Windows, and Flash Player for Windows using Wine on Ubuntu

–> Now browse to Quakelive.com using the Windows based Firefox, log in and then it will ask to download the Quakelive MSI. Dowload the MSI installer and use Wine for its installation.

–> Once this is done, restart Firefox, browse to Quakelive and it will update a few files which might take a while and once thats done you are all ready to get into Quakelive.


Shoaib Mir
shoaibmir[@]gmail.com

Categories: Operating Systems Tags: ,

‘public’ schema and Slony

April 8, 2009 4 comments

While setting up Slony the other day I found this weird problem…

I had like 8 schemas in my database and no schema named as ‘public’  and while trying to setup Slony for that specific database, during the INIT cluster step it started giving problems like…

“No schema available to setup objects”

I had no idea that its just a case of not having ‘public’ schema in there and as soon as I added an empty public schema, everything seemed to work fine and I was able to setup 8 sets for my 8 schemas and replication worked nicely as well.

Update: Just found out the problem came as I have deleted the public schema but the user’s search_path was defaulting to ‘public’ and changing that fixed the problem.


Shoaib Mir
shoaibmir[@]gmail.com

Categories: PostgreSQL Tags: ,